QuickOPC User's Guide and Reference
AllowZeroSecurityLevel Property (UAEndpointSelectionPolicy)



OpcLabs.EasyOpcUA Assembly > OpcLabs.EasyOpc.UA.Engine Namespace > UAEndpointSelectionPolicy Class : AllowZeroSecurityLevel Property
Specifies whether an endpoint with zero security level can be selected.
Syntax
'Declaration
 
<DefaultValueAttribute(True)>
Public Property AllowZeroSecurityLevel As Boolean
'Usage
 
Dim instance As UAEndpointSelectionPolicy
Dim value As Boolean
 
instance.AllowZeroSecurityLevel = value
 
value = instance.AllowZeroSecurityLevel
[DefaultValue(true)]
public bool AllowZeroSecurityLevel {get; set;}
[DefaultValue(true)]
public:
property bool AllowZeroSecurityLevel {
   bool get();
   void set (    bool value);
}
Remarks

A security level value of 0 indicates that the EndpointDescription is not recommended and is only supported for backward compatibility.

In order to obtain or modify this parameter, in the default state (when OpcLabs.EasyOpc.UA.EasyUAClient.Isolated equals to false), access EndpointSelectionPolicy property of UAClientAdaptableParameters.SessionParameters property of static OpcLabs.EasyOpc.UA.EasyUAClient.AdaptableParameters. If you have set OpcLabs.EasyOpc.UA.EasyUAClient.Isolated to true, you need to access EndpointSelectionPolicy property of UAClientAdaptableParameters.SessionParameters property of OpcLabs.EasyOpc.UA.EasyUAClient.IsolatedParameters.

Alternatively, you can override the endpoint selection policy for a specific endpoint by setting it to a non-null value in OpcLabs.EasyOpc.UA.UAEndpointDescriptor.EndpointSelectionPolicy.

Requirements

Target Platforms: .NET Framework: Windows 10, Windows Server 2012, Windows Server 2016; .NET Core, .NET 5: Linux, macOS, Microsoft Windows

See Also

Reference

UAEndpointSelectionPolicy Class
UAEndpointSelectionPolicy Members